Cómo resolver el error apt get stable oldstable


portada

En raras ocasiones cuando vayamos a actualizar los paquetes con APT encontraremos el siguiente mensaje.

Repository 'xxxxxxx' changed its 'yyyyy' value from 'stable' to 'oldstable'

La causa más probable para este fallo es que el repositorio haya pasado de una versión a otra. Por ejemplo, como indica el mensaje de error que he puesto, ha pasado de la versión ‘Stable’ a ‘oldstable ’

Mientras no solucionemos este fallo defecto no podremos instalar nuevos paquetes o actualizar los que ya tengamos instalados desde este repositorio.

Afortundamante, es sencillo evitar este mensaje de error. En primer lugar, nos aseguramos de que el mensaje de advertencia sea aceptable y no suponga, por ejemplo, un fallo de seguridad real para nuestro equipo.

Anuncio:

Sí estamos seguros de que todo es correcto, y de que queremos aceptar los cambios usamos el siguiente comando.

sudo apt-get update --allow-releaseinfo-change

De esta forma tan sencilla podemos terminar la actualización de los paquetes y continuar con el trabajo con APT con normalidad.

Anuncio:

Previous Tamaños de variables en ESP32, Arduino, Raspberry Pi, Windows y Linux
Next Wowki, un simulador online gratuito para Arduino o ESP32